Errore “Hai lanciato una vecchia versione di Firefox” su Ubuntu

Da un po’ di tempo, quando lancio Firefox sul mio PC Ubuntu 19.04 mi compare un messaggio che dice (in inglese) “You’ve launched an older version of Firefox”, e mi avvisa che questo potrebbe rovinare i miei preferiti e la mia cronologia di navigazione, per cui mi obbliga a creare un nuovo profilo o a rinunciare.

Certamente è possibile creare un nuovo profilo, e – a patto che abbiamo attivato in precedenza la sincronizzazione – importarvi i preferiti, la cronologia, riaprire le schede lasciate aperte, ecc., ma questo è un po’ scomodo, anche perché al prossimo aggiornamento del programma saremmo punto e a capo.

Il problema sembra causato da un bug introdotto nel pacchetto compilato per Ubuntu, ma è facilmente risolvibile: è sufficiente individuare sul disco il proprio profilo salvato dal browser, solitamente, su Linux, in

~/.mozilla/firefox/<stringacasuale>-default/ 

(https://support.mozilla.org/it/kb/Profili#w_individuare-la-cartella-del-profilo), editare il file compatibility.ini in esso contenuto svuotandolo, e modificarne i permessi in sola lettura, ad es. col comando

chmod 400 compatibility.ini

(https://wiki.ubuntu-it.org/AmministrazioneSistema/PermessiFile).

Da www.reddit.com.