Aggiornamento anticipato a Ubuntu 9.04 Jaunty Jackalope

Come sempre ho preferito aggiornare con qualche giorno di anticipo la mia installazione principale di Ubuntu (stavo già provando la nuova release su un’altra partizione dalla versione Alfa 5) alla nuova versione 9.04 Jaunty Jackalope, che sarà rilasciata definitivamente fra 7 giorni.

Ricordo a chi volesse evitare come me gli affollamenti del rilascio ufficiale, che l’aggiornamento può essere forzato con il comando

sudo update-manager -d

Il tutto è stato veloce e (abbastanza) indolore. Al primo riavvio si sono già notati i notevoli miglioramenti nei tempi di boot, di cui ho già riferito qualche giorno fa.

Ho avuto solo qualche piccolo problema legato al pacchetto flashplugin-nonfree.

Già durante l’installazione dei pacchetti scaricati infatti ho ricevuto varie notifiche sul fatto che flashplugin-nonfree aveva delle inconsistenze gravi o era difettoso, per cui non poteva essere aggiornato. Anche dopo il riavvio ogni tentativo di aggiornamento segnalava gli stessi errori. Non sono riuscito a risolvere correggendo il pacchetto difettoso con Synaptic né con apt-get -f install.

Alla fine ho risolto il problema con questi due comandi:

sudo dpkg --force-remove-reinstreq --remove flashplugin-nonfree
sudo apt-get install flashplugin-nonfree

Avevo anche provato ad installare direttamente flashplugin-installer ma con questo Firefox andava in crash con qualunque animazione flash.

Dicevo dei tempi di avvio notevolmente ridotti, anche se in questa installazione non lo sono così tanto come in quella di test. Sarà forse perché, mentre in quella ho usato il nuovo filesystem ext4 qui invece avevo formattato a suo tempo con jfs? Mi studierò un po’ la documentazione su ext4.

Chi aggiorna un’installazione su ext3 sappia che è possibile convertirla in ext4 seguendo queste istruzioni.

Sono graditi commenti con le vostre esperienze.

Hai trovato interessante questo articolo? Puoi iscriverti ai feed o ricevere i prossimi articoli per email.

2 pensieri su “Aggiornamento anticipato a Ubuntu 9.04 Jaunty Jackalope”

  1. stesso problema per me, non riesco a vedere nessun flash con firefox, con nessuno dei tre plugin sfwdec, gnash, adobe

Rispondi